87
Customers have installed this add-on in at least 87 active instances.
    by Simon Croomefor Bamboo Server 5.0 - 5.12.4.mistake
    Unsupported
    This add-on isn't formally supported, but you can ask a question via Atlassian Answers.

    Ask a question

    Unsupported
    This add-on isn't formally supported, but you can ask a question via Atlassian Answers.

    Ask a question

    Get it nowFree add-on

    Continuous Integration for Puppet code

    Continuous Integration for Puppet code

    Test code hygiene

    Fine-grained configuration

    Full test output

    Run puppet-lint and report failures

    All puppet-lint options are available

    Full puppet-lint output available

    More details

    Fixed in version 1.0.1:

    • Added a dummy test so that if there are no failing tests, there will be at least one passing test to allow the build to pass.

    This plugin currently provides integration with puppet-lint, a code hygiene analysis tool.

    Additional tests, such as syntax validation and remote serverspec tests are in development.

    The goal is to fully-automate continuous deployment of Puppet code using the Atlassian toolchain.

    User reviews

    (0)Sign in to write a review »

    There are no reviews yet. Be the first to review this add-on.

    Pricing

    Support

    Puppet Integration isn't formally supported.

    Versions

    Version 1.0.1 Bamboo Server 5.0 - 5.12.4.mistake Released 2016-01-22

    Summary

    Bug fixes

    Details

    • If there is no test result output because nothing is actually wrong, then no test results will be created, which means no passing test results, which means a failing build.

    Installation

    1. Log into your Bamboo instance as an admin.
    2. Click the admin dropdown and choose Add-ons. The Manage add-ons screen loads.
    3. Click Find new add-ons from the left-hand side of the page.
    4. Locate Puppet Integration via search. Results include add-on versions compatible with your Bamboo instance.
    5. Click Install to download and install your add-on.
    6. You're all set! Click Close in the Installed and ready to go dialog.

    To find older Puppet Integration versions compatible with your instance, you can look through our version history page.

    Similar add-ons