408
Customers have installed this app in at least 408 active instances.
    by Dieter Wimbergerfor Confluence Server 6.1.1 - 6.3.4 and more versions
    Versions available for Confluence Server 5.4.4 - 6.0.7
    Get it nowFree app

    Plugin that contains a macro for listing pages with links to this page, filtered by space and labels

    Plugin that contains a macro for listing pages with links to this page, filtered by space and labels

    Incoming Links

    Choose Rendering Style

    Flexible Sorting

    Use a simple macro to list pages that contain a link to the current page.

    Choose how the list should be rendered.

    Select sorting in normal and reverse order, for page title, creation and modification dates.

    More details

    Supported languages:

    • English
    • German

    Reviews for cloud

    (16)
    Sign in to write a review
    by Claudia Nitsche on 2017-07-31
    Thank you very much for your fast update!
    Was this review helpful?YesNo
    Dieter Wimberger

    I am using this in production, so usually I do support updates, just with slower cycles.

    by Sakari Maaranen on 2017-05-08
    Dear Dieter Wimberger, when I said that this add-on is not working, I am referring to the Confluence standard "Manage add-ons" user interface reporting with big red button reading INCOMPATIBLE - UPDATE REQUESTED and then in boldface letters: "This add-on is not compatible with your Confluence instance. An update for this add-on has already been requested from the vendor." This is on Confluence Server 6.1.0. Perhaps you have now updated the plugin for later versions - I have not tried it yet, but I am giving four stars this time, assuming that you have updated it, because I do like the feature. Perhaps you could coordinate with Atlassian to synchronize the plugin updates even better. For a sysadmin it is difficult to keep track of when to update to which version if there are many different plugins that are updated out-of-sync with Confluence itself. This problem is not specific to Incoming Links, but a general issue with Confluence add-ons.
    3 out of 3 found this review helpful
    Was this review helpful?YesNo
    Dieter Wimberger

    Hi Sakari,

    I know the issue, because it is also extremely difficult to keep up with the versions for me. Not just because I am the developer, but also because I heavily use this on production instances. I also do receive update requests for roughly 25% of the current install base ;) For other add-ons I have actually decided not to make them a plugin (LDAP and RADIUS that works against Crowd.)

    This plugin comes free and I can tell you that a lot of effort is going into keeping up the development and testing environment for Confluence versions. On my current machine, a single Confluence version to check against takes several minutes ~ 15 only to boot up the instance, with several versions from clean state that makes hours not minutes in work to try the most important version steps i.e. 6.0,6.1,6.2,6.3 ... and make sure it works.

    My suggestion as a Confluence "expert" is to drive a staging/production environment and use update cycles for Confluence that the company or client can manage. Larger companies usually will keep up doing this every 6 months.

    This is more or less the cycle I have been trying to keep with the plugin (because I have instances in production that are updated as well :)

    Regards,

    Dieter

    by Sakari Maaranen on 2017-05-02
    No longer working and the vendor isn't updating it. I did like it a lot when it was still working...
    0 out of 2 found this review helpful
    Was this review helpful?YesNo
    Dieter Wimberger

    Explaining what does not work and asking for help, sometimes can get you a long way.

    by Martin N on 2017-03-06
    Does not seem to have support for 6.0.6 - instantly crashed.
    0 out of 1 found this review helpful
    Was this review helpful?YesNo
    Dieter Wimberger

    I am not quite sure how to reproduce a crash with the small amount of information given here.

    Seems to work quite well actually. I have released a new build anyway, just in case something is going wrong with the build chain. Tested against 6.0.6, 6.0.7.

    Also a new build is available that should work with 6.1.x.

    by manser IT on 2016-09-01
    fast and easy plugin. Danke!
    Was this review helpful?YesNo
    Dieter Wimberger

    You are welcome.

    Reviews for server

    (16)
    Sign in to write a review
    by Claudia Nitsche on 2017-07-31
    Thank you very much for your fast update!
    Was this review helpful?YesNo
    Dieter Wimberger

    I am using this in production, so usually I do support updates, just with slower cycles.

    by Sakari Maaranen on 2017-05-08
    Dear Dieter Wimberger, when I said that this add-on is not working, I am referring to the Confluence standard "Manage add-ons" user interface reporting with big red button reading INCOMPATIBLE - UPDATE REQUESTED and then in boldface letters: "This add-on is not compatible with your Confluence instance. An update for this add-on has already been requested from the vendor." This is on Confluence Server 6.1.0. Perhaps you have now updated the plugin for later versions - I have not tried it yet, but I am giving four stars this time, assuming that you have updated it, because I do like the feature. Perhaps you could coordinate with Atlassian to synchronize the plugin updates even better. For a sysadmin it is difficult to keep track of when to update to which version if there are many different plugins that are updated out-of-sync with Confluence itself. This problem is not specific to Incoming Links, but a general issue with Confluence add-ons.
    3 out of 3 found this review helpful
    Was this review helpful?YesNo
    Dieter Wimberger

    Hi Sakari,

    I know the issue, because it is also extremely difficult to keep up with the versions for me. Not just because I am the developer, but also because I heavily use this on production instances. I also do receive update requests for roughly 25% of the current install base ;) For other add-ons I have actually decided not to make them a plugin (LDAP and RADIUS that works against Crowd.)

    This plugin comes free and I can tell you that a lot of effort is going into keeping up the development and testing environment for Confluence versions. On my current machine, a single Confluence version to check against takes several minutes ~ 15 only to boot up the instance, with several versions from clean state that makes hours not minutes in work to try the most important version steps i.e. 6.0,6.1,6.2,6.3 ... and make sure it works.

    My suggestion as a Confluence "expert" is to drive a staging/production environment and use update cycles for Confluence that the company or client can manage. Larger companies usually will keep up doing this every 6 months.

    This is more or less the cycle I have been trying to keep with the plugin (because I have instances in production that are updated as well :)

    Regards,

    Dieter

    by Sakari Maaranen on 2017-05-02
    No longer working and the vendor isn't updating it. I did like it a lot when it was still working...
    0 out of 2 found this review helpful
    Was this review helpful?YesNo
    Dieter Wimberger

    Explaining what does not work and asking for help, sometimes can get you a long way.

    by Martin N on 2017-03-06
    Does not seem to have support for 6.0.6 - instantly crashed.
    0 out of 1 found this review helpful
    Was this review helpful?YesNo
    Dieter Wimberger

    I am not quite sure how to reproduce a crash with the small amount of information given here.

    Seems to work quite well actually. I have released a new build anyway, just in case something is going wrong with the build chain. Tested against 6.0.6, 6.0.7.

    Also a new build is available that should work with 6.1.x.

    by manser IT on 2016-09-01
    fast and easy plugin. Danke!
    Was this review helpful?YesNo
    Dieter Wimberger

    You are welcome.

    Pricing

    Basic support resources are available for this app.

    Vendor support resources

    Documentation

    Find out how this app works.

    See existing Q&A in Atlassian CommunityAsk a question in the Atlassian Community

    Atlassian-hosted discussions connect you to other customers who use this app.

    Versions

    Version 1.0.11 Confluence Server 6.1.1 - 6.3.4 Released 2017-07-29

    Summary

    Compatibility

    Details

    Compatibility testing against newer Confluence Releases

    Installation

    1. Log into your Confluence instance as an admin.
    2. Click the admin dropdown and choose Add-ons. The Manage add-ons screen loads.
    3. Click Find new add-ons from the left-hand side of the page.
    4. Locate Incoming Links via search. Results include app versions compatible with your Confluence instance.
    5. Click Install to download and install your app.
    6. You're all set! Click Close in the Installed and ready to go dialog.

    To find older Incoming Links versions compatible with your instance, you can look through our version history page.

    Similar apps