471,468
Customers have installed this add-on in at least 1,468 active instances.

Behaviours Plugin

by Jamie Echlin for JIRA Server 6.3 - 6.3.15 and more versions
Versions available for JIRA Server 3.13 - 6.2.7
Supported
Jamie Echlin supports this add-on.

Get support

    Interactive client-side forms manipulation

    1

    2

    3

    1

    2

    3

    User reviews

    (47)
    Sign in to write a review »
    by Michael Kornatzki on 2015-04-02
    Hi Jamie, i like your plugin and now i try to upgrade from jira 4.4 to jira 6.4. I read that this plugin is no more supported but i have to use ScriptRunner. Can you please explain what i have to do to migrate my behaviours and the configuration to ScriptRunner? If you do it in the past then please excuse my question and maybe you can give me a link? Thakns, michael
    Was this review helpful?YesNo

    Vendor response

    Hi Michael, There is nothing really to do. After the upgrade install the latest version of script runner. Make sure behaviour is uninstalled. Everything else should just work.
    by Barbara Kohlroser on 2015-02-03
    Version 0.5.14 is now called "Jamie Echlin Plugin Info Plugin - Safe to remove" and the description reads "A plugin to tell you that you need another plugin". That is very confusing. Please change the name back so it contains the word "Behaviours" and can be recognised in the Add on List (JIRA 6.3.14) as such. When updating a list of Add-Ons it is not helpful to have such unrecognisable names.
    Was this review helpful?YesNo

    Vendor response

    Hi... in my defence this is the best I could do given marketplace's lack of support for retiring plugins. The alternative is that a user upgrades Script Runner, and they will get duplicate links for Behaviours, and maybe unexpected results. The intention is to tell people that upgrade that all functionality has been moved to the Script Runner plugin, and that they should install the latest version of that if not already installed, and remove the Behaviours plugin. cheers, jamie
    by Chengjiang Jin on 2014-04-28
    Hi Jamie, The plugin is very useful. But I found a serious bug for this plugin on "Make a field read-only except for a certain role". After set everything ok, the read-only users can't edit the constraint field by inline edit or by clicking "Edit" button to edit, but they CAN EDIT the constraint field by typying keyboard shotcut comma "," or dot "." to edit the constraint field. Could you help to take a look at this bug? Kindly Regards, Chengjiang
    3 out of 3 found this review helpful
    Was this review helpful?YesNo
    by Mincho Dimov on 2014-03-17
    Any plans for 6.2 support?
    4 out of 4 found this review helpful
    Was this review helpful?YesNo
    by Fabien Araktingi on 2014-02-28
    This plugin is very useful and we would like to know when it will be compatible for the jira 6.2 release please? "Sorry for the precedent comment I let with the (wrong) rate because it was not my intention. I rarely put post there so i didn't really know about this system..."
    8 out of 8 found this review helpful
    Was this review helpful?YesNo

    More details

    This plugin simply installs a servlet that advises that the Behaviours plugin has merged with Script Runner for JIRA.

    Script Runner can be downloaded from the marketplace. Once done, this plugin should be uninstalled.

    Free add-on FAQ

    Good news! This add-on is free.

    Support

    Jamie Echlin supports Behaviours Plugin. You can ask a support question via Atlassian Answers to get help.

    Ask a question

    Release notes

    Version 0.5.14 JIRA Server 6.3 - 6.3.15 Released 2014-07-10

    Summary

    Updated to point to the 3.0.0 version of Script Runner.

    Installation

    1. Log into your JIRA instance as an admin.
    2. Click the admin dropdown and choose Add-ons. The Manage add-ons screen loads.
    3. Click Find new add-ons from the left-hand side of the page.
    4. Locate Behaviours Plugin via search. Results include add-on versions compatible with your JIRA instance.
    5. Click Install to download and install your add-on.
    6. You're all set! Click Close in the Installed and ready to go dialog.

    To find older Behaviours Plugin versions compatible with your instance, you can look through our version history page.

    Similar add-ons