58
Customers have installed this add-on in at least 58 active instances.
    by Drunken Devfor Confluence Server 5.0 - 5.5.7 and more versions
    Versions available for Confluence Server 4.0 - 4.2.12
    Confluence Server 4.3 - 4.3.7
    Unsupported
    This add-on isn't formally supported, but you can ask a question via Atlassian Answers.

    Ask a question

    Unsupported
    This add-on isn't formally supported, but you can ask a question via Atlassian Answers.

    Ask a question

    Remove prior attachment revisions to free up space in your confluence instance

    Remove prior attachment revisions to free up space in your confluence instance

    Remove prior attachment revisions to free space

    Remove prior attachment revisions to free space

    Remove prior attachment revisions to free space

    Cull prior attachment versions by use of a scheduled job. It is first intended to get a job working to cull attachments based on age, though other configurable attributes may be added later.

    Cull prior attachment versions by use of a scheduled job. It is first intended to get a job working to cull attachments based on age, though other configurable attributes may be added later.

    Cull prior attachment versions by use of a scheduled job. It is first intended to get a job working to cull attachments based on age, though other configurable attributes may be added later.

    More details

    Plugin to Atlassian Confluence with the initial goal of culling prior attachment versions by use of a scheduled job. It is first intended to get a job working to cull attachments based on age, though other configurable attributes may be added later.

    I have called this the attachment tools plugin as I may decide at a later date to add other useful tools for attachments in here.

    User reviews

    (9)
    Sign in to write a review »
    by Jan-Peter Rusch on 2016-05-21
    Thanks for upgrading to the current Confluence version 5.9.10. Works like a charm!
    Was this review helpful?YesNo

    Drunken Dev

    Hi Jan-Peter. I am very sorry for the plugin not working. I am in the process of preparing an update for all versions through 5.9. An alpha has been prepared for 5.9.6 if you are on this version. If you are on a prior version please let me know and I shall look at preparing a version for your target instance.

    As the release is alpha please read the release notes and test on a test instance. 1.2.0-5.9-alpha-1

    by Michael Salisbury on 2015-03-24
    Hi there, this doesn't seem to be working for 5.7.1. The scheduled task says it's running, however there are still more versions than the limit I've set...
    Was this review helpful?YesNo

    Drunken Dev

    Unfortunately this is true. Atlassian made some breaking changes in 5.7. I'm presently working to resolve this though there is still issues with some of the way Confluence handles attachments internally that have resulted in some open issues.

    If you are on 5.9 you can take a look at an alpha release that I've published, please review the release notes though. 1.2.0-5.9-alpha-1

    If you're on a prior version let me know and I can prepare a release targeting the version you are on.

    by Hsu Yao Chang on 2014-09-28
    Hi gentman, I have download a trial version of confluence (Verson 4.3.5), and I try to install the plugin of Attachment Tools Plugin. After installed the plugin, I set the setting and run the schedule manually . But the page history does not remove by my setting . What's the reason ? Thank for your kindly help. (My Question: https://answers.atlassian.com/questions/8627319)
    Was this review helpful?YesNo

    Drunken Dev

    So sorry for the late reply. I have responded to the answers question.

    by stephen torra on 2013-10-18
    Hi Brett, We will be upgrading to 5.2. Is the plugin compatible? This would be a big help if it does. We've got thousands of attachment versions. Thanks -Steve
    Was this review helpful?YesNo

    Drunken Dev

    Sorry for the rather late response. The plugin is compatible with versions through to 5.6. As of 5.7 Atlassian made several breaking changes to the internals of confluence which I am working to resolve. This is still a work in progress as I await Atlassian engineers responses to assist with ongoing issues.

    You can download a pre-release alpha 1.2.0-5.9-alpha-1

    by ION Information Systems on 2012-10-17
    Hi Brett, This plugin looks good and just what we need but can I ask why it won't work on 4.2x of Confluence? Thanks, Gaj
    Was this review helpful?YesNo

    Drunken Dev

    Hi Gaj, the reason this plugin does not work with 4.2 and prior is that the plugin relies on an API function that was added to 4.3. This is the "Removing attachment versions" capability.

    https://confluence.atlassian.com/display/DOC/Confluence+4.3+Release+Notes#Confluence4.3ReleaseNotes-Otherimprovements

     

    Pricing

    Support

    Attachment Tools Plugin isn't formally supported.

    Versions

    Version 1.1.0 Confluence Server 5.0 - 5.5.7 Released 2014-07-01

    Summary

    Provides confluence 5.x support

    Details

    Provides corrections to revision selection, will now provide more details in reporting email.

    Confluence 5.x support added.

    Installation

    1. Log into your Confluence instance as an admin.
    2. Click the admin dropdown and choose Add-ons. The Manage add-ons screen loads.
    3. Click Find new add-ons from the left-hand side of the page.
    4. Locate Attachment Tools Plugin via search. Results include add-on versions compatible with your Confluence instance.
    5. Click Install to download and install your add-on.
    6. You're all set! Click Close in the Installed and ready to go dialog.

    To find older Attachment Tools Plugin versions compatible with your instance, you can look through our version history page.

    Similar add-ons