639
Customers have installed this add-on in at least 39 active instances.

Continuous Plugin Deployment for Bamboo

by Atlassian Labs for Bamboo Server 5.8.0 - 5.9.4 and more versions
Versions available for Bamboo Server 3.1 - 5.8.0
Unsupported
This add-on isn't formally supported, but you can ask a question via Atlassian Answers.

Ask a question

    Bamboo Tasks for continuous integration of Atlassian Add-ons

    Good for JIRA, Confluence, Bamboo, Stash and FECRU

    Compatible with Bamboo 5 Deployment Projects

    Used by Atlassians worldwide!

    Add a deployment step to your build pipeline to automatically install an Atlassian plugin to a remote system.

    Integrates seamlessly with your existing deployment pipeline

    Used by the Confluence, Team Calendars, JIRA, JIRA Service Desk, JIRA Agile, Atlassian Support, Atlassian Connect and Atlassian Foundation teams to deploy their projects.

    User reviews

    (6)
    Sign in to write a review »
    by Andrew Morin on 2013-12-18
    Not a review "yet". Will Bamboo 5.2 be supported at anytime?
    Was this review helpful?YesNo

    Vendor response

    We are running this plugin against Bamboo 5.2 internally here at Atlassian and we haven't had any problems. My bad for not keeping the release compatibility information on this site up-to-date - I've fixed it up now. Cheers! Joe Clark @ Atlassian.
    by Krzysztof Skoropada [InTENSO] on 2013-07-18
    Does this plugin support plugin type one ?
    Was this review helpful?YesNo

    Vendor response

    It will only support type 1 plugins for systems that support automatic reloading of them. As far as I know, only Confluence is able to automatically reload a type 1 plugin, so that should work. JIRA and other products did not support reloadable plugins until Plugins version 2.



    More details

    This Bamboo add-on provides an installation task for Atlassian Plugins, allowing you to set up a Continuous Integration ("CI") or Continuous Deployment ("CD") build for a plugin project.

    Free add-on FAQ

    Good news! This add-on is free.

    Support

    Continuous Plugin Deployment for Bamboo isn't formally supported.

    Release notes

    Version 3.0.7 Bamboo Server 5.8.0 - 5.9.4 Released 2015-06-30

    Summary

    Bamboo 5.9 compatibility

    Installation

    1. Log into your Bamboo instance as an admin.
    2. Click the admin dropdown and choose Add-ons. The Manage add-ons screen loads.
    3. Click Find new add-ons from the left-hand side of the page.
    4. Locate Continuous Plugin Deployment for Bamboo via search. Results include add-on versions compatible with your Bamboo instance.
    5. Click Install to download and install your add-on.
    6. You're all set! Click Close in the Installed and ready to go dialog.

    To find older Continuous Plugin Deployment for Bamboo versions compatible with your instance, you can look through our version history page.

    Similar add-ons