300
Customers have installed this app in at least 300 active instances.
    by SkyLime GmbHfor Bamboo Server 6.2.1 - 6.2.2 and more versions
    Versions available for Bamboo Server 5.0 - 6.1.4
    Supported
    SkyLime GmbH supports this app.

    Get support

    Get it nowFree app

    Ruby continuous integration for Bamboo

    Ruby continuous integration for Bamboo

    Tasks include Bundler, Capistrano, and Rake.

    Configure a runtime once per build/deploy plan.

    Use Bundler CLI to execute arbitrary commands.

    Tasks can be used for both build and deploy plans.

    No need to choose a ruby runtime per task, just choose per plan.

    Execute bundler CLI without restriction.

    More details

    For more information and instructions, please see the Bamboozled plugin on Github.

    ---

    This continuous integration/continuous deployment plugin for Atlassian Bamboo enables easy configuration of build and deployment tasks to run various ruby based build tools including bundler, rake, and capistrano. Works for both build and deploy plans, and allows for a single shared ruby runtime to be set in the miscellaneous tab.

    ---

    *Note on compatibility*: this is compatible with Bamboo 5.* regardless of the listing. The Atlassian marketplace does not allow for a wildcard minor version and requires an update with every Bamboo release so the listed "compatibility" may be behind.

    Reviews for cloud

    (6)Sign in to write a review

    There are no reviews yet. Be the first to review this app.

    Reviews for server

    (6)
    Sign in to write a review
    by Ben Jansen on 2017-10-18
    This plugin just works and makes working with RVM, Bundler, etc. much nicer.
    Was this review helpful?YesNo

    Pricing

    SkyLime GmbH provides support for this app.

    Vendor support resources

    Documentation

    Find out how this app works.

    Wiki

    Collaborative documentation platform hosted by this vendor.

    See existing Q&A in Atlassian CommunityAsk a question in the Atlassian Community

    Atlassian-hosted discussions connect you to other customers who use this app.

    Versions

    Version 6.2.0 Bamboo Server 6.2.1 - 6.2.2 Released 2017-10-27

    Summary

    Bamboo v6.2.x support

    Installation

    1. Log into your Bamboo instance as an admin.
    2. Click the admin dropdown and choose Add-ons. The Manage add-ons screen loads.
    3. Click Find new add-ons from the left-hand side of the page.
    4. Locate Bamboozled Ruby Plugin via search. Results include app versions compatible with your Bamboo instance.
    5. Click Install to download and install your app.
    6. You're all set! Click Close in the Installed and ready to go dialog.

    To find older Bamboozled Ruby Plugin versions compatible with your instance, you can look through our version history page.

    Similar apps