1,105
Customers have installed this app in at least 1,105 active instances.
    by JFrog Ltdfor Bamboo Server 7.0.2 - 7.1.3 and more versions
    Versions available for Bamboo Server 2.6 - 3.2.2
    Bamboo Server 3.3.2 - 4.1.2
    Bamboo Server 4.3 - 4.4.8
    Bamboo Server 5.0 - 5.0.1
    Bamboo Server 5.1.1 - 5.10.3
    Bamboo Server 5.11.0 - 6.10.6
    Supported
    JFrog Ltd supports this app.

    Get support

    Get it nowFree app

    Improved CI integration with Artifactory

    Improved CI integration with Artifactory

    Improved CI integration with Artifactory

    Full traceability for your builds

    New builder capabilities

    Upload/Download to and from Artifactory

    The Bamboo Artifactory plug-in brings the Artifactory CI Build Integration to Bamboo users

    Bamboo Artifactory plug-in currently provides full support for Maven 3, Gradle and Ivy builds. Generic Deployment Tasks are available for all builder types

    Smart, highly configured deploy capbilities

    More details

    Plugin Compatibility:

    The Bamboo Artifactory Plugin is fully tested for compatibility with the version of Bamboo that is current when the plugin is released. When a new version of Bamboo is released, the Marketplace lists the Bamboo Artifactory Plugin as incompatible, however, since we regularly update the plugin it is likely to maintain compatibility with patch or minor version upgrades of Bamboo. For a detailed compatibility matrix, please refer to the Bamboo Artifactory Plugin User Guide.

    Reviews for cloud

    (27)
    Sign in to write a review
    by eduardohl on 2017-03-22
    5.15.3 not supported
    3 out of 3 found this review helpful
    Was this review helpful?YesNo
    by Ralf Martin on 2017-01-11
    Happy to see the first version of type 2 (osgi) Plugin :)
    Was this review helpful?YesNo
    by Shashank Dhar Joshi on 2016-09-22
    Hi, I am trying to install it by putting version 1.5.6 jar for bamboo 4.4.0 into bamboo-home/plugins directory but It is showing to me that "This Plugin has NO MODULE" with version 0.0 Any help I can assume ?
    Was this review helpful?YesNo
    by David Stemm on 2016-09-16
    When will this plugin be compatible with Bamboo 5.13? Thanks
    Was this review helpful?YesNo
    by Elad Yaakov on 2016-06-02
    Thank you for your feedback Karol and Kayhan. I'm happy to update that the latest version is now compatible with Bamboo 5.11.x.
    Was this review helpful?YesNo

    Reviews for server

    (27)
    Sign in to write a review
    by Nataraj.Ramamoorthy-ext on 2020-08-12
    Doesn't support the latest bamboo (7.0.4) using 3.1.0v. Even support team response also very slow. Error Could not execute task 'Framework download and extracting' no Plugin with key 'org.jfrog.bamboo.bamboo-artifactory-plugin:artifactoryGenericResolveTask' is installed.
    Was this review helpful?YesNo
    by Johannes Appenzeller on 2020-06-30
    Nice idea, but non-standard and often awkward design and implementation choices, slow support. * Gradle tasks are not supported in deployment pipelines, only in build plans. After raising this issue with JFrog, the answer was that they don't consider this to be necessary. We support a community of 2500 developers and are planning to buy a commercial version of another gradle plugin to get this feature in. Sad. * Slow support for compatibility upgrades.
    Was this review helpful?YesNo
    JFrog Ltd

    We hope you've noticed that we've been updating the integration and find it satisfies your needs

    by Lisa Gordon on 2019-07-03
    Doesn't support Bamboo 6.9. JFrog seems to be more delayed than all our other plugin vendors which is frequently an issue for us.
    Was this review helpful?YesNo
    by Neil Borromeo on 2019-04-14
    Doesn't support Bamboo 6.8
    Was this review helpful?YesNo
    by Adam Melkus on 2018-11-20
    Generic deploy task doesn't support latest bamboo 6.7.1. Existing tasks work, but you can't modify or create new.
    Was this review helpful?YesNo
    JFrog Ltd

    Thank you for using the Artifactory plugin and providing your feedback.

    Please make sure that you are using the latest plugin version - currently 2.6.2. If the issue persists, it may be more convenient opening a github issue for our further discussion and treatment.

    Reviews for Data Center

    (27)
    Sign in to write a review
    by eduardohl on 2017-03-22
    5.15.3 not supported
    3 out of 3 found this review helpful
    Was this review helpful?YesNo
    by Ralf Martin on 2017-01-11
    Happy to see the first version of type 2 (osgi) Plugin :)
    Was this review helpful?YesNo
    by Shashank Dhar Joshi on 2016-09-22
    Hi, I am trying to install it by putting version 1.5.6 jar for bamboo 4.4.0 into bamboo-home/plugins directory but It is showing to me that "This Plugin has NO MODULE" with version 0.0 Any help I can assume ?
    Was this review helpful?YesNo
    by David Stemm on 2016-09-16
    When will this plugin be compatible with Bamboo 5.13? Thanks
    Was this review helpful?YesNo
    by Elad Yaakov on 2016-06-02
    Thank you for your feedback Karol and Kayhan. I'm happy to update that the latest version is now compatible with Bamboo 5.11.x.
    Was this review helpful?YesNo

    Cloud Pricing

    Server Pricing

    Data Center Pricing

    JFrog Ltd provides support for this app.

    Vendor support resources

    Documentation

    Find out how this app works.

    Wiki

    Collaborative documentation platform hosted by this vendor.

    Versions

    Version 3.1.0 Bamboo Server 7.0.2 - 7.1.3 Released 2020-03-31

    Summary

    Bamboo 7 compatibility

    Details

    Breaking change: Maven and Gradle - remove restriction of build-info collection only when deployment is configured.

    Bamboo 7 upgrade and compatibility.

    Tasks improvements.

    Installation

    1. Log into your Bamboo instance as an admin.
    2. Click the admin dropdown and choose Add-ons. The Manage add-ons screen loads.
    3. Click Find new apps or Find new add-ons from the left-hand side of the page.
    4. Locate Artifactory for Bamboo via search. Results include app versions compatible with your Bamboo instance.
    5. Click Install to download and install your app.
    6. You're all set! Click Close in the Installed and ready to go dialog.

    To find older Artifactory for Bamboo versions compatible with your instance, you can look through our version history page.

    Similar apps