666
Customers have installed this app in at least 666 active instances.
    by AdaptavistTop Vendor
    Adaptavist is a Top Vendor. Top Vendors have high standards for app quality, reliability, and support.

    Learn more

    for Confluence Server 5.9.8 - 6.11.2 and more versions
    Versions available for Confluence Server 2.1
    Confluence Server 2.2
    Confluence Server 2.3
    Confluence Server 2.7 - 5.9.4
    Confluence Server 5.9.7
    Supported
    Adaptavist supports this app.

    Get support

    ThemeBuilder is THE web-development tool for Confluence. Fully customise your user interface with HTML, JavaScript and CSS

    ThemeBuilder is THE web-development tool for Confluence. Fully customise your user interface with HTML, JavaScript and CSS

    ThemeBuilder is THE web-development tool for Confluence. Fully customise your user interface with HTML, JavaScript and CSS

    Reflect your brand across your intranet

    Powerful built-in functionality

    Easy-to-use scripting console & theme manager

    Build themes to brand your company's Confluence experience or specify themes for each teams space

    ThemeBuilder has over 30 macros that allow you to build more powerful Confluence and content experiences. Customise page layout, functionality and behaviour

    Keep your code in order with our straight-forward theme manager and easily add your page customisations with our script console

    More details

    ThemeBuilder gives you the ability to customise your Confluence look and feel using HTML, CSS and JavaScript. Create an intranet or documentation experience that is intuitive and reflects your brand.

    With ThemeBuilder you can:

    • Easily customise and rearrange Confluence using building block styled code modules
    • Develop completely custom page layouts by scripting macros and HTML
    • Customise Confluence's UI and pages by showing or hiding elements
    • Showcase visual content using the carousel feature
    • Ensure the longevity of your theme by building standardised layouts that match the Confluence codebase.

    Reviews for cloud

    (18)
    Sign in to write a review
    by Katarina Nikolic on 2017-06-26
    All stars for Sharon Hinde! Great and fast responses.
    Was this review helpful?YesNo
    Adaptavist

    Hi Katarina,

    Thank you so much for your review! We always strive to provide excellent support, so it's great to get feedback like this. Please feel free to contact us again if you need anything.

    All the best,

    Dylan Lindsay

    Adaptavist Product Marketing

    by Larry Stern on 2016-10-07
    Speedy and thorough response to my request by Rob Parish is greatly appreciated!
    Was this review helpful?YesNo
    Adaptavist

    Hi Larry,

    Thank you so much for your review. Please do not hesitate to get back to us in case of any issue.

    Regards,

    Rafael

    by Juan Jose del Rio on 2016-03-28
    We are trying to upgrade our Confluence to the latest version, but this plugin only supports up to 5.9.4. Thinking on removing it, as we need 5.9.5 or newer due to an Atlassian fix ( https://jira.atlassian.com/browse/CONF-40630 )
    2 out of 2 found this review helpful
    Was this review helpful?YesNo
    Adaptavist

    Hi Juan,

    My name is Rafael Franco and I'm the Tech Lead for the Product team here at Adaptavist. Atlassian introduced severe changes to the Dashboard in the latest 5.9.5 which broke ThemeBuilder. We're working really hard to get that update as soon as possible for our clients because we understand how important it is.

    Could you send me an email so I can contact you as soon as we have the fix in place? rfranco@adaptavist.com

    Thanks,

    Rafael

    by CeDiS FU-Berlin on 2016-01-25
    Hi everybody, unfortunately it is not possible to create any new pages in spaces styled by the themebuilder plugin, version 5.3.6 installed on the latest confluence version. The wysiwyg editor is not being fully loaded. Please refer to the error report we just created on your support desk and provide a fix as soon as possible! Thanks UPDATE: We solved this issue. It is caused by installation specific configurations and NOT really by the ThemeBuilder itself. Thanks to the Adaptavist-Team for the quick help!
    1 out of 1 found this review helpful
    Was this review helpful?YesNo
    Adaptavist

    Hi,

    We have released the Themebuilder version 5.3.7 which is compatible with Confluence 5.6 - 5.9.4 versions in the marketplace. Please know the fix for your issue has been included in the new version. Please check the release notes for more details. If you have any other queries, please do not hesitate to contact us.

    Kind Regards

    Divya Margani | Adaptavist.

    by Sasha Pantic on 2014-10-02
    Any ETA for 5.6? What is the chance of keeping up with Confluence releases, what is the average time for catching up with latest Confluence version?
    Was this review helpful?YesNo
    Adaptavist
    Hi Sasha,

    ThemeBuilder is scheduled for development over the coming weeks and we'll be releasing a 5.6 compatible version toward the start of November. The majority of the clients we talk to have an internal upgrade cycle on a quarterly basis and we aim to fit into this schedule with our compatibility releases - which means compatibility releases within 1-3 months after a major Confluence release; we apply extra care to our testing, including testing the security and performance aspects of our solutions which extends the upgrade cycle as we believe this is the level of quality our customers require.

    Adaptavist Product Team

    Update: ThemeBuilder v. 5.1.0 compatible with Confluence 5.6 is now available

    Reviews for server

    (18)
    Sign in to write a review
    by Jeremy Swan on 2018-09-24
    Thank you Sharon, for pointing out the more in depth documentation. Example themes would be great. I'm working on an adaptation of the US Design System for Confluence using Theme Builder, which I hope to share on github: us design system: https://designsystem.digital.gov/
    Was this review helpful?YesNo
    Adaptavist

    Hi Jeremy,

    my name is Sharon Hinde and I'm the Lead Theme Developer here at Adaptavist. I want to thank you for this comprehensive review of ThemeBuilder, and respond to one point you mentioned on having to buy support in order to use features in the add-on. To clarify - all features and macros of ThemeBuilder, including image carousels, are included in the licence fee. We have a page on how to create an image carousel in our documentation (https://www.adaptavist.com/doco/display/tb/Carousel%3A+Container+and+Page), where every feature and macro is documented.

    Kind Regards

    Sharon

    by Zach Mitchell on 2018-04-06
    Great team, addressed any issues we found immediately.
    Was this review helpful?YesNo
    Adaptavist

    Hi Zach,

    Thank you very much for the review!

    Please feel free to reach out again if you need anything.

    All the best,

    Dylan

    Adaptavist Product Marketing

    by Katarina Nikolic on 2017-06-26
    All stars for Sharon Hinde! Great and fast responses.
    Was this review helpful?YesNo
    Adaptavist

    Hi Katarina,

    Thank you so much for your review! We always strive to provide excellent support, so it's great to get feedback like this. Please feel free to contact us again if you need anything.

    All the best,

    Dylan Lindsay

    Adaptavist Product Marketing

    by Larry Stern on 2016-10-07
    Speedy and thorough response to my request by Rob Parish is greatly appreciated!
    Was this review helpful?YesNo
    Adaptavist

    Hi Larry,

    Thank you so much for your review. Please do not hesitate to get back to us in case of any issue.

    Regards,

    Rafael

    by Juan Jose del Rio on 2016-03-28
    We are trying to upgrade our Confluence to the latest version, but this plugin only supports up to 5.9.4. Thinking on removing it, as we need 5.9.5 or newer due to an Atlassian fix ( https://jira.atlassian.com/browse/CONF-40630 )
    2 out of 2 found this review helpful
    Was this review helpful?YesNo
    Adaptavist

    Hi Juan,

    My name is Rafael Franco and I'm the Tech Lead for the Product team here at Adaptavist. Atlassian introduced severe changes to the Dashboard in the latest 5.9.5 which broke ThemeBuilder. We're working really hard to get that update as soon as possible for our clients because we understand how important it is.

    Could you send me an email so I can contact you as soon as we have the fix in place? rfranco@adaptavist.com

    Thanks,

    Rafael

    Reviews for Data Center

    (18)
    Sign in to write a review
    by Katarina Nikolic on 2017-06-26
    All stars for Sharon Hinde! Great and fast responses.
    Was this review helpful?YesNo
    Adaptavist

    Hi Katarina,

    Thank you so much for your review! We always strive to provide excellent support, so it's great to get feedback like this. Please feel free to contact us again if you need anything.

    All the best,

    Dylan Lindsay

    Adaptavist Product Marketing

    by Larry Stern on 2016-10-07
    Speedy and thorough response to my request by Rob Parish is greatly appreciated!
    Was this review helpful?YesNo
    Adaptavist

    Hi Larry,

    Thank you so much for your review. Please do not hesitate to get back to us in case of any issue.

    Regards,

    Rafael

    by Juan Jose del Rio on 2016-03-28
    We are trying to upgrade our Confluence to the latest version, but this plugin only supports up to 5.9.4. Thinking on removing it, as we need 5.9.5 or newer due to an Atlassian fix ( https://jira.atlassian.com/browse/CONF-40630 )
    2 out of 2 found this review helpful
    Was this review helpful?YesNo
    Adaptavist

    Hi Juan,

    My name is Rafael Franco and I'm the Tech Lead for the Product team here at Adaptavist. Atlassian introduced severe changes to the Dashboard in the latest 5.9.5 which broke ThemeBuilder. We're working really hard to get that update as soon as possible for our clients because we understand how important it is.

    Could you send me an email so I can contact you as soon as we have the fix in place? rfranco@adaptavist.com

    Thanks,

    Rafael

    by CeDiS FU-Berlin on 2016-01-25
    Hi everybody, unfortunately it is not possible to create any new pages in spaces styled by the themebuilder plugin, version 5.3.6 installed on the latest confluence version. The wysiwyg editor is not being fully loaded. Please refer to the error report we just created on your support desk and provide a fix as soon as possible! Thanks UPDATE: We solved this issue. It is caused by installation specific configurations and NOT really by the ThemeBuilder itself. Thanks to the Adaptavist-Team for the quick help!
    1 out of 1 found this review helpful
    Was this review helpful?YesNo
    Adaptavist

    Hi,

    We have released the Themebuilder version 5.3.7 which is compatible with Confluence 5.6 - 5.9.4 versions in the marketplace. Please know the fix for your issue has been included in the new version. Please check the release notes for more details. If you have any other queries, please do not hesitate to contact us.

    Kind Regards

    Divya Margani | Adaptavist.

    by Sasha Pantic on 2014-10-02
    Any ETA for 5.6? What is the chance of keeping up with Confluence releases, what is the average time for catching up with latest Confluence version?
    Was this review helpful?YesNo
    Adaptavist
    Hi Sasha,

    ThemeBuilder is scheduled for development over the coming weeks and we'll be releasing a 5.6 compatible version toward the start of November. The majority of the clients we talk to have an internal upgrade cycle on a quarterly basis and we aim to fit into this schedule with our compatibility releases - which means compatibility releases within 1-3 months after a major Confluence release; we apply extra care to our testing, including testing the security and performance aspects of our solutions which extends the upgrade cycle as we believe this is the level of quality our customers require.

    Adaptavist Product Team

    Update: ThemeBuilder v. 5.1.0 compatible with Confluence 5.6 is now available

    Cloud Pricing

    Server Pricing

    Data Center Pricing

    10 users$1025 users$45050 users$900100 users$1,350250 users$2,750500 & upAdditional pricing details

    Pricing FAQ

    How does server app pricing work?

    Server products and apps are hosted on your servers. This app is sold as a perpetual license, and the purchase price includes 12 months of maintenance (support and version updates).

    You can renew maintenance after 12 months at 50% of the current purchase price. You can upgrade the tier of your Atlassian product and app licenses at any time. Upgrade prices are calculated based on Atlassian's formula (view example).

    If app pricing changes after your initial purchase, there's a 60-day grandfathering period during which you can renew based on the old pricing.

    How do I determine my server pricing?

    Apps are billed based on the number of users in your Atlassian product. The app tier should match the licensed user tier of the Atlassian product. For example, if you have a Confluence license for 500 users, you should purchase the 500-user tier for apps. Even if fewer users want to use the app than your Atlassian product license, the two licenses should match exactly.

    Can I install this app in a Data Center product?

    This app does not have a a Data Center approved version. Only apps meeting a set of performance requirements for large, clustered environments are approved for Data Center.

    However, while server apps are built for single-server deployments, many customers successfully install them in Data Center products. If you're using a Data Center product, Atlassian recommends you contact the vendor to determine compatibility at scale.

    Learn more about Data Center approved apps

    What type of license do I need if I'm using this app in a Data Center product?

    Because this app does not have a Data Center approved version, you should purchase a Server license if you decide to install this app in a Data Center product.

    Learn more about Data Center licensing

    Do you offer academic, community, or open-source licenses for server apps?

    For server apps, academic licenses are available at a 50% discount if you have an academic license for your Atlassian product.

    Community and open-source licenses are available for server apps. Learn more about community and open source licenses.

    Can I extend my free trial?

    For server apps, you can extend your app trial up to 5 times - in other words, for up to six months. Extend your trial by generating a new evaluation license key from Atlassian Marketplace. Click Try it free and you'll be directed to generate a new license. Paste this license key into the app listing in UPM from your Atlassian product, and you're all set.

    How can I buy apps for my legacy Jira Server or Confluence Server license?

    If you own a legacy Jira Server Unlimited (100+ users) or Confluence Server Unlimited (2000+ users) license purchased in 2012 or earlier, legacy app pricing is no longer available. You have two options for app purchasing:

    • Purchase the app at the non-legacy Unlimited (10000+ users) tier.
    • Renew your Jira or Confluence license at a non-legacy tier, then purchase the app at the same tier.

    Learn more

    Adaptavist is a  Top Vendor, committed to providing support for their apps at least 8 hours a day, 5 days a week.

    Vendor support resources

    Documentation

    Find out how this app works.

    See existing Q&A in Atlassian CommunityAsk a question in the Atlassian Community

    Atlassian-hosted discussions connect you to other customers who use this app.

    Versions

    Version 5.7.2 Confluence Server 5.9.8 - 6.11.2 Released 2018-08-20

    Summary

    Carousel now has an option for image alt text - Confluence 6.11.0 Compatibility

    Details

    ThemeBuilder is Confluence 6.11.0 Compatible.

    Added the ability to provide a description for images when using the Carousel macro, using the technique described here http://davidmacd.com/blog/alternate-text-for-css-background-images.html.

    The alt text is now an additional parameter in the macro options.

    Read the Carousel Macro documentation

    Read all ThemeBuilder release notes

    Installation

    1. Log into your Confluence instance as an admin.
    2. Click the admin dropdown and choose Atlassian Marketplace. The Manage add-ons screen loads.
    3. Click Find new add-ons from the left-hand side of the page.
    4. Locate ThemeBuilder for Confluence via search. The appropriate app version appears in the search results.
    5. Click Try free to begin a new trial or Buy now to purchase a license for ThemeBuilder for Confluence. You're prompted to log into MyAtlassian. ThemeBuilder for Confluence begins to download.
    6. Enter your information and click Generate license when redirected to MyAtlassian.
    7. Click Apply license. If you're using an older version of UPM, you can copy and paste the license into your Confluence instance.

    To find older ThemeBuilder for Confluence versions compatible with your instance, you can look through our version history page.

    Similar apps